The network name cannot be found

Apr 22, 2009 at 1:08 PM
Hi all,

Using MOSS 2007 on win2k3 r2 with netware client 4.91 sp4.

I have created the local user to match the novell user and used that credential in the crawl rule.....haven't specified it with acontext though ie not admin.container just admin

I have seen this on a couple of installs now, when I try and crawl the netware file share it throws up the above error? I know this is not directly related to the trimmer but......

On the latest install I have tried it fails as it executes the stsadm at the end of the msi installer with this entry in the eventviewer:

 

Product: NetwareSecurityTrimmer(x86) -- Error 1722. There is a problem with this Windows Installer package. A program run as part of the setup did not finish as expected. Contact your support personnel or package vendor. Action _6BC0C285_57C0_4A61_B201_1599CCB319AA, location: C:\Program Files\Microsoft\NetwareSecurityTrimmer(x86)\STSADM.EXE, command: -o registersecuritytrimmer -ssp SharedServices1 -id 80 -rulepath "file://nfs-share1/*" -typeName "NetwareSecurityTrimmer.SecurityTrimmer, NetwareSecurityTrimmer, Version=1.0.0.0, Culture=neutral, PublicKeyToken=e0fffb020b774993" -configprops "NetwareFileServer~nfs-share1~CheckLimitProperty~200~SecurityCheckAccount~SharePoint_search~SecurityCheckPassword~******~WebServiceUrl~"

Any help with either problem would be greatly appreciated?

Thanks

Steve

Apr 23, 2009 at 8:48 AM
Just as an update!

The network name cannot be found is down to the strange way sharepoint tries to access the volume, a wireshark trace showed sharepoint tries to:

Access the share with the windows search service account in the form of searchservice.domain in edir then searchservice in bindery.
Then it tries the crawl rule account in the same form username.domain and then the binderery object of just username.
So if your windows domain or computername don't match the context which the netware account is in, it will fail
AND
if you have no bindery setup (who does?) it will fail.

It may be worth mentioning this in your pre-requisites!

Still no idea about the second problem?